2005 4L60E Trailblazer FIXED

2005 4L60E Trailblazer FIXED

Postby bobs71 » Thu Apr 20, 2017 6:42 pm

Sporadic wrong gear take off( every one to two days)Changed VB, Sol. TFP . Nothing changed outcome. The only thing I see Strange is the TFP logic. It Shows Invalid. In most ranges. Also Shows One logic in park and another in neutral Think theses should be the same in both positions. Have I got a computer issue or any Ideas.. Despite the fact this always show invalid it work good most of the time.???????
bobs71
 
Posts: 57
Joined: Thu Aug 28, 2014 12:09 pm

Re: 2005 4L60E Trailblazer

Postby carod » Thu Apr 20, 2017 10:11 pm

what about the prndl switch? I would check or change it.
carod
 
Posts: 75
Joined: Wed Aug 10, 2016 6:53 pm
Location: Calgary, Alberta

Re: 2005 4L60E Trailblazer

Postby bobs71 » Fri Apr 21, 2017 8:55 am

yes have checked PRNDL, matches as should in all ranges on scan tool. We've only been able to feel problem once. when it did it , we stopped put it in park did not shut off engine, then back to drive it working normal then. Cu. does tell us it does not act up until it's been driven about 20 min.
bobs71
 
Posts: 57
Joined: Thu Aug 28, 2014 12:09 pm

Re: 2005 4L60E Trailblazer

Postby dhritsko » Fri Apr 21, 2017 9:11 am

The MLPS can do crazy things even if they check right . Also check the connections real good , have seen loose or dirty pins cause some weird things , also make sure grounds are clean
Dave Hritsko
Transtar Industries
Technical Service Manager
User avatar
dhritsko
 
Posts: 1023
Joined: Mon Oct 28, 2013 3:43 pm
Location: Walton Hills , OH

Re: 2005 4L60E Trailblazer

Postby bobs71 » Tue Apr 25, 2017 9:48 am

Well thanks again guys.. Replaced PRNDL despite the fact it showed good. This fixed my bad readings on the TFP.
bobs71
 
Posts: 57
Joined: Thu Aug 28, 2014 12:09 pm

Re: 2005 4L60E Trailblazer FIXED

Postby dhritsko » Tue Apr 25, 2017 10:08 am

crack the old one open and see if you can tell what went wrong , sometimes there are signs of bad connection or corrosion inside .
Dave Hritsko
Transtar Industries
Technical Service Manager
User avatar
dhritsko
 
Posts: 1023
Joined: Mon Oct 28, 2013 3:43 pm
Location: Walton Hills , OH


Return to GM Automatic Transmissions

Who is online

Users browsing this forum: No registered users and 2 guests